I am always tripped by Godot Jargon
Well on the one hand you could submit an idea for a forum improvement to automatically regex all capitalised references to become URL links to the docs where applicable, but tbh this may do more harm than good and be a nightmare to maintain (kinda would be nice though, some questions may even answer themselves lol).
On the other hand, just bookmark this page and over time as you read more of the docs you will become more used to what's available in the API and learn the terminology. Scenes & Nodes are the second link.
Also if people refer to a class or term you don't recognise, it is likely in this list and if not the search function in the top left:
I've been using Godot for about a year, and pretty much will be in the docs on the daily looking something up. There is no shortcut for this, it's the best place to learn.
Ultimately, this is exactly what would happen when learning any other API pretty much ever. I mean, almost nothing in Godot is actually identical to implementations in other engines, as even similar classes will have functions that may differ in name and/or nuances in execution. E.G
https://docs.unity3d.com/ScriptReference/Vector3.html
vs.
https://docs.godotengine.org/en/stable/classes/class_vector3.html
vs.
https://docs.unrealengine.com/4.27/en-US/API/Runtime/Core/Math/FVector/
vs.
https://developer.valvesoftware.com/wiki/Vector
vs.
https://docs.cryengine.com/pages/viewpage.action?pageId=29448783
vs....
This is not limited to Godot. It's rare that anything ever does and should never be assumed.
As for creating new nomenclature for existing documented Godot terms, this strikes me as the opposite of user/beginner-friendly as your just adding an abstraction layer for seemingly no reason and I (and I imagine many others) would vote no on that. It would only make sense if at an engine level you renamed everything and prefixed it with something, but doing this is just a horrible redundant naming practice in general.
I mean, you wouldn't do this right...
class MyClass():
def MyClass_MyFunction():
pass